You are here: Download Web>WindowsInstaller (03 Feb 2012)

The following instructions are for installing Opus and UrbanSim on Windows using the Opus Installer. These installation directions have been tested with Windows XP and with Windows 7 32 bit.

NOTE 1: We have had no problems with the installer on Windows XP or Windows 7. We have not tested this installer on Vista, but some users had difficulties with earlier installers on the Vista platform.

NOTE 2: Please be aware that we have removed from this installer the database interfaces that were in the installer previously, due to the variability in which platforms users are using. Once you decide on a DBMS to use with UrbanSim, you will need to install an appropriate Python interface to that DBMS. Read the material below for details.

Installer of Stable Release of OPUS

4.4.0 (Recommended) 4.4.0 release
4.3.2.2 4.3.2 with packages for travel model interfaces included
4.3.2 bug fixing of version 4.3.1
4.3.1 List of the packages included
4.3.0 List of the packages included
4.2.2 List of the packages included

To test if your installation was successful, go to start menu and select Programs, Opus, OpusGUI Opus. It should launch the graphical interface to Opus and UrbanSim. Then do File, Open Project, and select the eugene_gridcell project. In the Scenarios tab of the GUI, select the Eugene_baseline scenario, right-click, and run. Click the start run button and if this completes, you should have a working install.

Please give us feedback on your experience with the installer: what operating system did you use, and how well did the installer work for you?

Zip Snapshot of Stable Releases

If you don't need to install Python and supporting packages (because you have done it already or are working on a platform that is not Windows 32-bit, you can get a zip snapshot of stable releases, You will need to be sure you have the necessary python packages installed and your environment variables set properly.

4.4.0
4.3.2
4.3.1
4.3.0
4.2.2

DBMS Interfaces

OPUS and UrbanSim use the SQLAlchemy package to connect to all of the database platforms supported by that library. For a complete list of the DBMS platforms and links to the Python libraries to interface to them, use this link: http://www.sqlalchemy.org/docs/dbengine.html#supported-databases

Links to snapshots of the main DBMS platforms that are in wide use by the UrbanSim user community will also be provided below for Windows users that have used the above installer (based on Python 2.6).

MySQL

Some users report a problem with the MySQLdb python module that interfaces to MySQL in Python 2.6. Re-install it with this package: http://www.technicalbard.com/files/MySQL-python-1.2.2.win32-py2.6.exe (assuming you're using python2.6 on windows 32 bit) Some discussion of the problem can be found in the UrbanSim mailing list: http://mailman-mail5.webfaction.com/pipermail/urbansim-users/2010-April/000132.html

ArcGIS Notes

Are you an ArcGIS user? Please read our ArcGIS notes before running the OPUS installer.

Note that as of ArcGIS 10, which (finally) supports Python 2.6, the installation concerns above will no longer apply. Installation of both OPUS and ArcGIS 10 should be simple and painless.


 

Topic revision: r21 - 03 Feb 2012 - 07:46:14 - LimingWang
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback